Wii firmware breaks Freeloader

Author:
Publish date:

It has emerged that following

yesterday's release

of Nintendo's version 3.0 firmware for Wii, Datel's Freeloader, a piece of software that allows users to play US and Japanese games on their PAL Wii, is no longer compatible with the machine.

Freeloader originally appeared for use on GameCube, but has subsequently been released for Wii. Whilst it does not allow for the playing of imported Wii titles, it does allow gamers to play overseas GameCube titles on their machine.

Seeing as Freeloader is an unofficial product, it seems unlikely that Nintendo will issue a fix for the disc, though the company is remaining tight-lipped for the moment.

Related